Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,223   Posts: 1,532,491   Online: 1076
      
Results 1 to 6 of 6
  1. #1

    Join Date
    Feb 2008
    Location
    Rochdale , lancashire , UK
    Shooter
    35mm
    Posts
    50

    problem with olympus xa

    Love this little camera to bits but just noticed today that the shutter speed
    display has stopped working.

    The shutter still works properly and exposure is still corect it's just that the
    needle in the viewfinder seems to be ''stuck''

    both batteries checked and are ok for voltage.

    Anyone else had this ?

    pquser.

    Bob.rochdale uk

  2. #2
    Peter Black's Avatar
    Join Date
    Mar 2005
    Location
    Scotland, UK
    Shooter
    Multi Format
    Posts
    1,001
    Images
    23
    I've had this or a similar problem with the meter, but you're correct in saying that it just keeps working anyway. My one is sufficiently old that it is past repairing and I don't use it that often anyway, but exposure still seems pretty accurate and Ilford XP2 would be printable even if it was a couple of stops out. You'll need the batteries for the shutter release as well as the meter. I'd just live with it!

  3. #3
    Mark Fisher's Avatar
    Join Date
    Dec 2003
    Location
    Chicago
    Shooter
    Medium Format
    Posts
    1,627
    Images
    151
    I've had that happen before too. Since the XA is handholdable at very slow shutter speeds, I never found it to be a problem....then I lost it and had to buy another one (:

  4. #4

    Join Date
    May 2007
    Location
    Tallinn, Estonia
    Shooter
    35mm
    Posts
    118
    Images
    22
    I read somewhere that the XA actualy has two lightmeters. One for the shutter and other for the needle in the viewfinder. If so, then I guess just the needle meter isn't working.

  5. #5

    Join Date
    Feb 2008
    Location
    Rochdale , lancashire , UK
    Shooter
    35mm
    Posts
    50
    Hi everyone....good news

    the camera just fixed itself !!

    thanks for your commets.

    pquser

  6. #6
    Steve Smith's Avatar
    Join Date
    May 2006
    Location
    Ryde, Isle of Wight
    Shooter
    Medium Format
    Posts
    8,589
    Images
    122
    I have a problem with my XA at the moment too. I can't find it!


    I have noticed that they can become a bit 'quirky' if the battery contacts are not perfectly clean.


    Steve.
    "People who say things won't work are a dime a dozen. People who figure out how to make things work are worth a fortune" - Dave Rat.



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin