Switch to English Language Passer en langue franšaise Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 75,163   Posts: 1,658,506   Online: 757
      
Results 1 to 8 of 8
  1. #1

    Join Date
    Jun 2011
    Shooter
    35mm
    Posts
    82

    Yashica 14e question

    I just picked this up after a brief inspection, one thing I thought was odd is that the aperture ring doesn't have any detents on the various stops. Is it supposed to be this way or did I just buy a broken camera? (wouldn't be the first time!)

    Other than that the camera seems to be in good shape, I also haven't been able to get the battery door off since Yashica has kindly not included a slot to help open it.

  2. #2
    olleorama's Avatar
    Join Date
    May 2009
    Shooter
    Multi Format
    Posts
    526
    Images
    5
    Mine was like that too. A bit like shutter priority mode.

    I used a piece of a rubber mat to get the friction needed to open the battery hatch.

  3. #3
    zsas's Avatar
    Join Date
    May 2011
    Location
    Chicago, IL
    Shooter
    35mm RF
    Posts
    1,962
    Images
    74
    Ditto re non-click stops

  4. #4

    Join Date
    Apr 2011
    Location
    Yukon, OK
    Shooter
    Medium Format
    Posts
    277
    1+ on the no detent thing too. I hope your battery door isn't difficult to open because of a leaking battery. Please tell us how that works out. Although you lose the meter, the camera works well without it as I recall and wait until you see the results with B&W with that camera and color even seems to be "retro" on it too.

    It is a fun, small, and wonderful camera.....enjoy being asked about it. NOBODY and I mean nobody shows up anymore around my area with one around their neck.

    Bob E.
    Nikon F5, Nikon F4S, Nikon FA, Nikon FE, Nikon N90, Nikon N80, Nikon N75, Mamiya 645 Pro, Mamiya Press Super 23, Yashica Lynx 14e, Yashica Electro GSN, Yashica 124G, Yashica D

  5. #5

    Join Date
    Jun 2011
    Shooter
    35mm
    Posts
    82
    Thanks for the replies, I did manage to get the battery cover off with a little piece of innertube. There wasn't a battery in there, so it looks like I'm good to go except that I don't have a battery for it I pulled the battery from my GX (yashica guy adapter) and tried it out with no luck, I guess I'll place an order for yet another adapter.

  6. #6
    zsas's Avatar
    Join Date
    May 2011
    Location
    Chicago, IL
    Shooter
    35mm RF
    Posts
    1,962
    Images
    74
    A 14e takes 2 batteries easily found on the bay for a couple dollars

    Let me see where I got mine...

  7. #7
    zsas's Avatar
    Join Date
    May 2011
    Location
    Chicago, IL
    Shooter
    35mm RF
    Posts
    1,962
    Images
    74
    ^, yep this is what I bought, two of the below, did the trick for my 14E

    http://www.ebay.com/itm/A640PX-1-5V-...item334da7c4d0

  8. #8

    Join Date
    Apr 2008
    Shooter
    Medium Format
    Posts
    9
    I have the 14 and the 14e; neither have that traditional "click" ( detent) when moving the aperture ring from F-stop to F-stop. Normal condition for these great cameras. I think that you'll very pleased with it, the lens is very fast and very sharp.



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  Ś   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin