Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,550   Posts: 1,544,858   Online: 1074

Apparent Issue with Polaroid Back

  1. kwall
    Hi all,

    I have the camera and Polaroid back mentioned. Should both the rollers on the back's business end move freely? On mine, one does, one doesn't. After pretty thorough cleaning I got a lot of crap out of the rollers, but the bottom roller (closest to the camera body) seems stiff. Consequently, when I load pack film and pull the dark slide from the pack to expose the first frame, the paper rips off. That seems wrong.:

    Any cleaning or repair suggestions, or should I just find another back?

    Thanks!

    Kurt
  2. analoguey
    analoguey
    Will be getting a polaroid back soon myself, wondering what was your solution to this?
  3. analoguey
    analoguey
    Update

    Have run through about 3-4 packs on my backs. One of the rollers *was* stiff, and there was enough gunk that the cleaning took me an hour (cotton swabs / savlon / wet cotton / dried) but the pictures have come out decent, and there hasnt been any tearing.
    The solution seems to be what has been generally recommended both on Fuji film packs and on the web: Pulling out the white/black tabs straight as well as the Film tab.
  4. John Koehrer
    John Koehrer
    Generally it's as you think, goop on the rollers. I use rubbing alcohol to clean them, it's a bit faster than water & won't hurt anything.
    You may have to work the roller a bit to really free it up.
Results 1 to 4 of 4


 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin