Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 71,049   Posts: 1,561,090   Online: 769

Is Camtech still the place to get om's repaired?

  1. snapshot2000
    I have a new, almost never-been-used Om4T. I took it out of the box, put straps on it and loaded with film. All worked fine the first time or two, and then the winder jammed and it won't advance and the shutter won't fire. I'm guessing the lubricants have dried up. Does that sound like a major fix? Also, been holding off because the repair cost on Camtech is about $200. Is this the best place to send it?

    Thanks in advance,

    Dan
  2. onepuff
    onepuff
    Have you tried changing the batteries? These cameras lock up if the shutter is fired with the batteries nearly flat.
  3. Fernando
    Fernando
    About the batteries suggestion: no, not the 4T (or 4Ti) - the batteries are an issue in the plain OM 4, which has had three or four revisions of its circuitry. When the problem was solved, the 4T(i) was launched. Anyway, check the batteries as this rules for any electronic camera and be sure they put out 1.55V. The Energizer are recommended by some knowledgeable users (check the Olympus mailing list archives, search Tim Hughes' posts), but I've used the Swiss-made Renata with no problems. I own both the 4 and the 4Ti, and batteries are an issue in the 4 only.

    The jammed shutter is a known issue of both 4 and 4Ti, not so in the 2n or plain 2, 1n or plain 1. Don't know about the 2s or 2sp, and never heard a 3Ti or plain 3 suffering this.

    And yes, John Hermanson can fix it.
  4. George S.
    George S.
    Fernando, Other OMs, not just the plain "4" will lock up the shutter with weak, or old batteries that may test "OK". OMs like fresh, silver oxides, never alkaline or lithium.
    The reason you never heard of an OM-3 or 3Ti with this problem is those cameras have mechanical sutter system and will work without batteries.
    The "battery issue" with the "4" is that it goes thru batteries at a faster rate than any other OM, so that is why the shutter may lock up- there is more chance of having weak batteries.
  5. mopar_guy
    mopar_guy
    George,
    The OM-4, OM-4T, OM-2S can become physically jammed and the film wind lever will not move and the shutter will not release even on the mechanical 1/60 sec. setting. The only fix is to have the camera disassembled and put back together again.

    Dave
  6. George S.
    George S.
    Hi Dave,
    Of course any mechanical camera can suffer a jam, but my post was with regard to batteries, (see how many times I mentioned batteries above?) Battery related jams is what I thought Fernando was referencing.
  7. snapshot2000
    snapshot2000
    Thanks everyone. Just got it back from repair and it's like brand new. (Actually, I don't think it's ever been used.)

    It needed a stripdown and clean. I think the lubricants turned to gunk from sitting in the box for 10 years or however long it was there.

    Looking forward to using it now!

    Dan
Results 1 to 7 of 7


 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin