Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 71,837   Posts: 1,582,441   Online: 738

Shutter Jam with my OM-2n

  1. Uncle Bill
    Single digit OM gear has been pretty much reliable workhorses for me when out hiking and travelling. Well back on Sunday my OM-2n about half way through a roll suffered a shutter/film advance jam. A little back story I picked this camera up on Ebay about four years ago for about $60 from a local seller. Worked great, pretty much the only thing I had to do was re-seal it and get a #4 Hotshoe. I know it has to go in for a CLA, I guess the big question is, this a common occurrence with with OM-2ns?
  2. Allan Swindles
    Allan Swindles
    Hi Uncle Bill,
    I have two OM-2 bodies and one OM-2n. I've not experienced any problems such as you describe, generally very reliable. BUT, and I don't mean to teach gran'mar t' suck eggs, are the batteries OK. When I was in the trade most of the problems I encountered were due to battery failure or even the incorrect type fitted. The OM system single digit cameras need silver oxide batts. Many folk use others 'cause they're cheaper. Just a thought, but you already know that don't you........shut up Allan!
  3. Uncle Bill
    Uncle Bill
    I use the proper silver oxide batteries, I even replaced them with fresh pair to eliminate that issue, still jammed.
  4. PeteD
    PeteD
    I've had it happen with an OM1n and an OM2sp but not with an OM2n. The OM1n I got repaired but I can't find anyone who'll do the OM2sp.

    Pete
  5. Allan Swindles
    Allan Swindles
    Hi Uncle Bill, is this a coincidence or what? A couple of days ago I was about to take a shot (1/500@f8) when the shutter jammed. It turned out to be dud batteries and once replaced I was back in business. Yesterday, new batteries in camera, again just about to take a shot and the shutter locked and would not wind. Confused and desperate I pressed the reset button and set the shutter to 'B' and what do you know, the mechanism released. I was in a rush when I grabbed the camera and I think I may have inadvertantly pressed the reset button when I picked it up. It's worked fine today so I wonder if this might solve your problem.
Results 1 to 5 of 5


 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin