Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,557   Posts: 1,545,193   Online: 1023

Fungus...

  1. beegee675
    Wondering what experiences other Oly people have with lenses that have shown some kind of fungus issues. If you've experienced it, at what point was it noticable? What were the conditions that might have made the the fungus present? What did you do about it? There's a lot of us who are picking up lenses that are 30- or so years old and it seems that invariably there's going to be a percentage of them that has these issues. I have a 50mm 1.4 that might have the beginnings of something, but it's hard to tell...

    -Bob G.
  2. wblynch
    wblynch
    I got a 50/1.8 "Japan" version with a parts camera that had fungus and moisture in the front group. I left it out in the hot sun for a couple of afternoons and in a sunny window for a week.

    The fungus went away but there were moisture and dust marks remaining. I opened the lens to try and clean it and that's when I learned that the "Japan" and "made in Japan" versions have a sealed front group that can't be opened.

    I heard from John Hermanson that the famous "over 1.1million" version of the 50/1.4 is also built the same way.

    I decided that I don't want these versions of the lenses anymore. I like lenses that can be cleaned.
Results 1 to 2 of 2


 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin