Odd question, but will the new version be compatible with older browsers?
I only ask this as sites that upgrade to newer java for example won't function well with my old os, trying to spend money on paper and chems rather than a new computer!!

Cheers.