Couple of things....

Try pushing a button "AF-ON" just right of your view finder. Does autofocus work? There is a setting in CSM (Custom Setup) where it would disable half-shutter-button-focus. You might have accidentally turned it off. In that case, what LyleB said will help. In addition, there are two kinds of master reset. Here's how to do both:

1) push CSM and MODE simultaneously and hold them for more than 2 seconds (master reset)
2) During two button reset (see above), custom setting indicator "CUSTOM" will blink or 2 seconds. Release one of the two bottons once while CUSTOM indicator is blinking, then press both buttons again.

If you have a manual, it's on page 76. If you don't, I'll be glad to e-mail you a copy.