Good morning, Anthony;

Of all of the accessories for the Minolta X-700 (and the two minor variants, the X-570 and X-370), the MD-1 Motor Drive is one of the most useful accessories. For me, it places the shutter release button right where my index finger expects to find it. The combination just seems to fit my hand. It is worth making the repair to have this most useful accessory on your camera. The film advance capability is a nice addition, and the additional weight does help in holding the camera still when taking a photograph.

You seem to have the basic concepts in mind in your efforts to get it to work for you. All that I can really suggest is to continue to clean and remove any oxidation from the contacts and connecting parts. A special cleaning solvent you can find at electronics supply houses is something that may be called "DeOxit," or something similar. A bit of vinegar on the surfaces may also help with removing that oxidation, but clean the contacts afterward. When it is gone, preventing normal oxidation again from just being exposed to the air is the next step, since some of the protective plating probably is gone from some of the contact surface points. My own preference for something to help that is a light smear of silicone grease applied to those contact points. It will keep the air away from the surfaces while also allowing the pressure to displace it enough for electrical contact.

Keep trying and working at it. It will get better. And that is all that I can really offer to you without actually disassembling and examining the MD-1 myself.