I'd say you don't need the current edition. I have one which is either the previous edition, or the one previous to that (if that makes any sense), and it covers the 500 series thoroughly.