The weird artifacting definitely is introduced with the scanning; like mentioned, make sure ICE / infrared dust removal is turned OFF in your settings.