Not yet! (Requires iOS6 because of the Facebook integration -- no judgement as to Facebook being good or bad).