Awesome! Is there an API keeping you from 5.0.1 compatibility? That would allow me to use it on my personal phone, rather than on the work test phone or my girlfriend's phone.

Yeah, I'm the IT guy tied to old versions of OSes . . .