Regarding the cords: shouldn't the cord marked 120V go to the wall socket and the cord marked timer plug into the back of the timer that says "enlarger". Also, some electronic timers seem to have issues with this enlarger.

To test your enlarger, you can plug both plugs into the power strip/wall socket.


Quote Originally Posted by lightwisps View Post
I have the same enlarger and love it. Recently moved so I had to pack up the enlarger. When it was all unpacked and assembled I was so excited, Time to plug it in and print!! I had the same problem. Mine is about 13 years old so the bits and pieces might be a bit different. Mine has a small black box labeled "Saunders/LPL regulated power supply that only has an of-off switch. It has to outgoing cords. One is a bit short and says to timer. Nope, it plugs into your surge protector. The other much longer cord says 120vac 60HZ. That plugs into the socket on the timer. Mine is a Graylab 450. Only has one socket that you can put a 3 pronged plug into. Anyway a guy on APUG told me to do all this and it worked like a champ. I had already changed to a new bulb and was looking up how to repair the power supply. Problem solved. Hope this works for you. You have one hell of an enlarger. Don