Try a different ISO setting.

If that has no improvement set the minimum ISO and maximum ISO three times and then try the above ISO setting.

Noel