Thanks for helping me.


The shutter is a «Synchro Compur-P» With flash setting «X and M» with shutter speeds B and 1-1/500s. The shutter speed selection ring is easy to move until you try to set it to 500. It then becomes a bit hard to push. The same goes when you try to push the shutter crank lever. It’s easy to crank at all speeds except at 500 when it becomes pretty hard to push the crank.

Pictures from ebay listing (click to see large version):
angulonfront.jpg angulonrear.jpg


I tried the shutter one more time before posting this post and it actually worked a couple of times but then reverted back to the issue I stated tin my first post


«shutter finger» I don’t think that is the shutter i have. Se pictures above. But do you think the advice you gave still applies to my type of shutter. Is there a guide for that one as well or is it to old? I tried to google my problem but could not find any answers. I really hope this is a relatively easy fix that I can mange to do myself (fingers crossed)


Again many thanks for helping me!!


Thomas