The Nikon F4 I have now is a replacement for another one that could not load the film properly. This one seemed to be working fine, but I have found out that when pointing the camera to a bright source, the shutter fires, the red led starts blinking and the camera gets locked. This occurs in the Ph, P and S modes and always when a lens is on the camera. In modes M and A there is no problem. I take care not to get a HI indication in the viewfinder, and it seems that it occurs even when setting the ISO to 50, point the camera to a lamp and get it locked even at speeds of 1/250 sec or slower.
The lenses that I have tried with it are the Nikkor 50mm 1.8D and the 35-80 G. Using both lenses I get the same problem. and it happens with, or without the DP-20 attached. If I remove the lens, then everything works fine.
All speeds work fine and the aperture gets correctly set all the way from 1.8 down to 22.
Also, when I set the ISO high, say ASA3200, I get the same effect even in low lit scenes. I have tried everything, even fresh batteries, but I could not resolve the problem.
I have tried the same lenses in the other body and at the same modes, and it does not exhibit this. I have also tried the
What could be wrong with it? Could it be something easy to fix? Is it something I am doing wrong?