Did you double check the settings on the sekonic?