Jon, last night I received an email from a Polish user of the "Konica SLR users" Yahoo Group. He owns a T4 that a couple of moths ago got jammed...Here's the message:

"It sounds like the camera is jammed. It is very likely that something
simply got stuck. I would try to open the bottom of the camera and
delicately try to wiggle the linkages about very gently, without
force. If you tug gently on the winder level while looking inside the
camera from the bottom, you can figure out what linkage does what. I
had this same problem with my T4 just a couple of months ago, and
after playing around with it for 5 minutes it got unstuck. I really
don't know what got it stuck in the first place, but that did it.
Good luck. You just might get lucky. Just remember to be gentle, slow,
and don't force anything (what does this remind me of...?). "


I had already tried before similar methods to yours (...smack the heel of your other hand with the base of the camera...) and to the one described in the email with no succes.

After reading that email I opened back the bottom plate and tried to find the misterious linkage...and I was lucky...I found a kind of lever with a metallic cylinder head (more or less described), moved it and the shutter fired completely.

If someone needs detailed info I could send him some photos.

Thanks Jon.

Saludos.