Quote Originally Posted by Max Power
Hey Joey,
The main symptom is that the shutter wouldn't fire and thus, nothing would advance. I have a parts XG-M that does this too.

Some things to check:
1. Are your batteries OK?
2. Does the shutter fire? Intermittently?
3. Do the internal LEDs light up?

Let me know what your exact symptoms are and I might be able to help more.

Kent
Kent: I ran and got the camera as soon as I read your reply. What happened next is very strange...

I turned the camera on and checked out the l.e.d.s in the viewfinder...they worked fine. I then attempted to release the shutter...nothing. But I said to myself, it shouldn't fire, because I had removed the old roll and could not advance the new roll. Thus the shutter wasn't cocked and wouldn't fire. I tried winding the advance again...nothing. I tried it a second time...it now clicked a couple of times at the extreme end of the lever's throw. Pressed the shutter release, and it fired! Wound again and it fired! What gives?

Is this the intermittancy (is that a word?) that you described?

And to answer your other question, I don't have any hesitation using a soldering iron and would jump at the chance to repair it, if I had a reasonable expection that I would get the beast back together again. Thanks for your help.

Joe