A couple things to try and why:
1) are you using digital ice?
if so try it without
2) Try a raw scan (no optimization), wide gamut, full bit depth (48?). Open in PS, apply levels (first set the options in levels to:enhance per channel,shadow and highlight clip at .10) select auto.

Much like a a traditional print there appears to be 'blooming' were the extreme highlite and shadow meet (although in a trad print the blooming occures in the highlight). So you would want to turn off anything that would be causing the scanner to make multiple passes such as ice.

There is a smaller chance that the software is 'enhancing' the shadow detail. The raw scan using the widest gamut should catch it.

Hope that helps. nice image