At the top of the sidebar click "Customize Sidebar" then on that page "Select where you want the sidebar to appear:" select "Disabled" and save the change