hell, this developer is for "expired film", it's not outdated... don't know where I had my brain when I wrote that